hyqd.net
当前位置:首页 >> EClipsE错误提示 >>

EClipsE错误提示

rt.jar 有一定的限制,无法访问.的解决办法eclipse遇到报错:访问限制:由于对必需的库 F:\Program Files\Java\jre7\lib\rt.jar 具有一定限制.默认把这些受访问限制的API设成了ERROR,你只要把 窗口-->首选项-->Java-->编译器-->错误/警告-->禁止的引用(访问规则)(F):将“错误”改为“警告”就可以了.具体设置如图所示:

从头看环境变量的配置,肯定有地方错了. 我以前遇到过这个问题.安装jdk的时候,注册表中有jdk的信息,但是你配置环境变量的时候配置确实错的.eclipse启动的时候可能有时候用的是注册表的信息,有时候用的是环境变量的信息.另外,在eclipse的配置jre位置的时候,最好指定为jdk的目录,而不是jre的目录,因为前者能看到源码.jre指的是java的运行环境,也就是java虚拟机,运行java程序必须要有jrejdk 是java开发者工具包,包含jre.你要用eclipese开发java程序,至少你自己必须能运行调试java程序吧,所以你必须要先安装jdk或者jre,建议装个jdk.

解决eclipse下编辑js的报错提示 Requesting JavaScript AST from selection解决办法: eclipse设置 Window-->Preferences->Javascript-->Editor-->Mark Occurrences然后取消选中 'Mark occurrences of the selected element in the current file',也可能是环境问题没配置好,导致的.

你的80端口被占用了,在任务管理器中关闭占用该端口的进程就可以了

可能是这2种情况导致的:1.环境变量没配置2.eclipse和jdk版本位数百不一致,要同是32位或者64位(注意32位机子只能度使用32位的,64位可以专兼容使用32位和64位的) 如果你不想配置环境变量的话,可以修改eclipse目录下的eclipse.ini,在第1,2行加上属配置即可(自己修改为自己的javaw.exe所在目录):-vm C:/Program Files (x86)/Java/jre7/bin/javaw.exe

关闭:Window-->Preferences-->General-->Editor-->Text Editors-->Annotations-->Error 取消右边show in的三个复选框,就可以关闭错误提醒了.打开,则勾选上这几个选项.

1、查看java环境变量是否配置成功 . 2、查看环境配置是否配置多余的版本jdk版本路径,只能配置一个版本环境变量 3、打开eclipse.ini文件 . 4、在换jdk版本时,在下列文件中对应位置更改版本,更改为当前路径版本. 5、另外电脑配置的内存过小也会导致eclipse无法打开,如按照下图示进行更改. Eclipse是一款开发工具而言对开发人员来说就是生产工具,如果你在使用此生产工具时也遇到了以上问题无法使用而困扰时,不妨试试上面的方法来解决.

没有勾选自动编译?或者自动检查周期没到吧.解决方案:1. 处理改正后还报错的,找到下方的 Problems 选项卡,删除对应的错误.2. 有错误不提示的,在左侧项目上点击右键,选择 validate

选择window-preferences-myeclipse-validation将右边的build下面的选 上这样如果你的项目设置为自动构建的话就会提示了

重新配置jdk环境变量,这是因为类库找不到

网站首页 | 网站地图
All rights reserved Powered by www.hyqd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com